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Software intro
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Introduction

◼ HC Touch VPro

⚫ HC Touch VPro Configuration Software is a configuration screen development tool 

for HCFA's V-series HMIs. It is an integrated development environment.

⚫ Advantages of the Software :

1.Comprehensive Functionality: Equipped with a complete range of controls including graphics, 

buttons, numerical values, alarms, recipes, etc., meeting common customer needs. It also supports ma

cro instruction functions to fulfill complex functional requirements.

2.Rich Protocol Support: Compatible with all series of Hechuan control products. Includes main

stream controller protocols in the market. Supports tag communication (under development).

3.Convenient Project Editing: Features such as multiple duplication, support for table import/

export operations, installment - payment, and password generation tools significantly improve progra

mming efficiency.

4.High - Level Security: Protected by project passwords, upload/download passwords, user permi

ssion passwords, installment - payment passwords, and automatic project backup during version update

s to ensure project security.

5.Easy Debugging: Supports offline/online simulation, transparent transmission, remote downloa

d and other functions, facilitating on - site debugging.

6.Cloud Services: IoT series HMIs support remote download of HMI projects, network transparent 

transmission, and mobile APP monitoring/operation of devices.

HC Touch 
VPro



Menu bar

Tool bar

Program editing interface

⚫ The layout of the software interface after opening the project is shown in the figure above. The overal

l interface is mainly divided into the menu bar, the toolbar, and the program editing interface. 

◼ An Overview of the Software Interface
Software intro
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◼ Introduction of the Menu Bar - 1 介绍
Introduction

⚫ File ⚫ Home

⚫ Project

⚫ Object

Software intro



⚫ The menu bar is the most frequently used 

during the editing of the HMI program. Usi

ng the menu bar flexibly can enable you to 

complete the project more quickly. 

介绍
Introduction

⚫ Data/History

⚫ View⚫ IIOT

⚫ Tool ⚫ Cloud

Software intro
◼ Introduction of the Menu Bar - 2



◼ Software version

Click [file] -> [about] of the menu

Note: If the software version is too low, some functions may not be available or other abnormalities may occur. You need to update it 

online or contact the customer service to upgrade to the latest software version. 
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Introduction

Software intro



1.

2.

HC Touch VPro software intro

Basic Functions of Software

CONTENTS



◼ Create a new project

⚫ Step ①: Click "File" -> "New" in the menu bar

⚫ Step ②: In the New Project window, select "Open New 

File", then choose the model of the HMI

Basic Functions of the Software
功能

function

①

②



◼ System Parameters - 1 功能

function

Note: *1. The printer function is still under development. 

⚫ Click “Home" -> "System Parameters" in the menu bar.

1. Devices: Used to set the properties of the devices that the HMI is intended to connect to, including the local dev

ice, remote HMIs, or controllers.

2. HMI Properties: Set the HMI model, HMI orientation, clock source, printer*1, and the width of the scroll bar, etc.

3. General Properties: Set various parameters related to the screen operation, such as the initial window, properties 

of the public window, screen saver settings, default keyboard settings, etc. 

① ② ③

Basic Functions of the Software



4. System Settings: Set various parameters of the HMI, such as the default display language, communication delay, au

tomatic logout of permissions, sound control, etc. 

5. Remote *1 : Set the relevant settings when the HMI is connected remotely. 

6. User Password: Set user permissions and passwords, and multiple types of permissions can be configured. There ar

e two modes: the general mode and the advanced security mode. 

7. Time Synchronization/Daylight Saving Time*1: Keep the time of the HMI consistent with the NTP server. 

◼ System parameters intro -2 功能

function

Note: *1. Functions such as remote access, time synchronization, and DST(daylight saving time) are still being improved and cannot be used for the time being. 

④ ⑤ ⑥

Basic Functions of the Software



◼ Communication between HMI and Controller - Ethernet Communication Setup 功能

function

Note: *1. You can also click on [Address 

Configuration] and select the protocol 

driver in the pop-up window. 

⚫ Click on [Common] -> [System Parameters] in the menu bar.

1. Step ①: In the system parameters window, select the [Device] section and click the [Add Device] button.

2. Step ②: In the device properties window, select the protocol driver*1 of the controller and the communication interface 

type, and then click the [Settings] button below.
3. Step ③: In the device properties window, select and set the communication parameters. (Taking the M511S controller as an 

example, the IP address is 192.168.88.100 and the port number is 502.) Finally, click [OK].

① ②

③
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◼ Communication between HMI and Controller - HMI Settings 功能

function

⚫ Ethernet communication requires that the HMI and controller are on the same network 

segment, and the HMI IP is set as follows

1, step ①: HMI power on, open the system settings (HMI settings button in the lower right   corner of 

the point open, select the first is the system settings, you need to enter the password (default: 111111);

2, Step 2: Enter the system, in the [Network] column select the use of the following IP address, and c

onfigure the IP address is shown below (to IP address 192.168.6.121 as an example); finally click [Apply] 

-> [OK]
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◼ HMI communicates with the controller - Serial Port Setting 功能

function⚫ Click [Home] -> [System Parameters] in the menu bar;
1.Step 1: In the system parameters window, select the [Device] column, click the [New Device] button:

2.Step 2: In the device properties window, select the controller's protocol driver * 1 and the interface type of 

communication, and then click on the following [Set] button;

3.Step 3: In the device properties window, select and set the communication parameters (here with the M511S for 4

85 communication as an example, the communication parameters for the baud rate of 9600, 8 data bits, 1 stop bit, no pa

rity), and finally click [OK];

4.Step 4: configure the address in the component properties, the need to modify the communication station number, 

as shown in Figure 4 ("2 #" on behalf of the station number 2) settings:

① ②

③

④
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◼ HMI and controller serial communication wiring 功能

function

⚫ HMI Serial Communication Pin Definition

You can click [Communication Port Pin Definition 

View] in the Device Properties window as shown below:

Click the corresponding size of the touch scree

n model in the help to view the pin description;

Note: The touch screen pins of the engineering 

prototype refer to [Conventional Model];
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⚫ ① 7-inch/10.1-inch HMI PORT1 interface *1 diagram is shown below:

功能

function

⚫ ② 4, 3 inch / 15.6 inch HMI PORT2 interface DB9 pin definition, as shown below:

Note: *1, 4.3‘ and 15.6’ touchscreens do not have a PORT1 interface.

②
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◼ Create new window

⚫ Step 1: After selecting [Window] in the left to

olbar, select a blank window in the catalogu

e tree and click [Add] with the right mouse b

utton;

◼ Step 2: After setting the screen-related prop

erties in the pop-up window, click OK to crea

te a new screen; the screen properties are de

scribed as shown below:

组态

WINCC

1、Name: the name will be displayed in the control bar of the window a

nd the catalogue tree of the toolbar [Window];

2、Size: set the size of the window, the default and the resolution of 

the HMI; 

3, window overlap: when the same component needs to be placed in more 

than one window, then you can use the overlapping window to achieve; up to 

three windows can be selected as the background, the background window with

in the window components will be appearing in the window in order;

4、Monopoly: after checking the it, the window as a pop-up/direct/indi

rect window use, the window is popped up after his pop-up window and the ba

ckground window operation will be completely suspended;

5、Pop-up window: the basic window can also be used as a pop-up window, 

you can set the pop-up coordinates, the origin of the coordinates is the up

per left corner of the screen;

6、Macro Command: Set the macro command to be executed cyclically when 

the window is opened/closed;
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◼ Edit Project Screen

⚫ Step 1: After selecting [Window] in the left toolbar, 

double-click to select the window established in th

e catalogue tree [Basic Components]; click on the d

esired control in the [Components], [Information/H

istory] in the menu bar; take [Numerical Values] as 

an example:

功能

function

⚫ Step 2: Click the menu bar [Object] -> [Numeric], 

configure the address, format, etc. in the compo

nent properties window, click [OK]; click to place 

the [Numeric] component in the program editing 

interface;
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◼ Save Project and Project Encryption

⚫ Save Project *1 : You can use the shortcut key (Ctrl+S), or click [Save File] in 

the File menu bar.

Project Encryption: Click [Home] -> [System Parameters] in the menu bar; I

n the popped-up System Parameters window, select the User Password col

umn, check the option of Enable Project File Password, and set the passwo

rd; After completing the settings, before editing the project file, the user w

ill be required to enter the password, and can only access the project file b

y entering the correct password.

功能

function

Note：*1. When creating a new project, you need to save it first. The project file will be 

generated only after setting the project name and save directory.
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◼ Project Compilation

⚫ Step ①: Click [Project] -> [Compile] in the menu bar.

⚫ Step ②: Configure the compilation and download 

parameters, and finally click [Start Compilation].；

功能

function

◼ Step ③: The progress bar will indicate the compila

tion progress. Once the compilation is finished, th

e window will display the compilation details. Fina

lly, click [Close] to finalize the compilation task.
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◼ Project Download - Network Download

⚫ Step ①: Click [Project] -> [Download (PC→HMI)] 

in the menu bar.

⚫ Step ③: After configuring the relevant parameters, click [Dow

nload]. The progress bar in the middle will display the downlo

ad progress. Once the download is completed, a window indic

ating that the HMI has been restarted successfully will pop up. 

Click [OK] to complete the download task. 

Note: Do not interrupt the connection to the HMI during the downloa

d process, and refrain from performing any other operations; otherwi

se, it will affect the transmission. 

功能

function

⚫ Step ②: The project will be automatically compiled b

efore downloading. You can only download the proje

ct after the compilation is successful. In the Downloa

d (PC→HMI) window, there are two methods as follo

ws:

1. Download by specifying the IP address: Set the IP 

address of the HMI (take the IP address of the HMI as 192.

168.88.121 as an example here);

2. Download by specifying the HMI name: Use [Search A

ll] to search for all HMIs within the same network domain. 

①

②
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◼ Project Download - USB Flash Drive Download 1

⚫ Step ①: Click [Project] -> [Create Download D

ata] in the menu bar.

⚫ Step ③: Click [Create]. Once completed, a p

op-up window will appear indicating that t

he download data has been successfully cre

ated.

功能

function

⚫ Step ②: The project will be automatically compiled before downloadi

ng. You can only start downloading the project after the compilation i

s successful. In the pop-up window, select the directory where the pro

ject will be saved (In here, save it in the installation directory of the US

B flash drive).

Basic Functions of the Software

Note: Do not interrupt the connection to the HMI during the downloa

d process, and refrain from performing any other operations; otherwi

se, it will affect the transmission. 



◼ Project Download - USB Flash Drive Download 2 功能

function

⚫ Step ④: Plug the USB flash drive into the tou

chscreen, then select [Download] in the pop-

up window on the HMI.

⚫ Step ⑤: Configure the download settings in t

he pop-up window on the HMI, enter the dow

nload password (the default password is 111

111), and then click [OK].

⚫ Step ⑥: Select the project package to be 

downloaded in the pop-up window on th

e HMI, click [OK], and wait for the downlo

ad to complete.

Basic Functions of the Software

Note: Do not interrupt the connection to the HMI during the downloa

d process, and refrain from performing any other operations; otherwi

se, it will affect the transmission. 



◼ Project Upload - Network Upload 1 功能

function

⚫ Step ②: In the pop-up "Upload (HMI->PC)" windo

w, there are two methods:  

1.Upload via Specified IP: Set the IP address of the HM

I (e.g., `192.168.88.121`).  

2.Upload via Specified HMI Name: Click [Search All] to 

scan for all HMIs within the same network domain.

⚫ Step ①: Click [Upload (HMI->PC)] under [File] in th

e menu bar.；

⚫ Step ③: Select the HMI model and the proje

ct save path, click [Upload], and wait until t

he data reception is complete.
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◼ Project Download - USB Drive Upload 1 功能

function

⚫ Step ①: Plug the USB flash drive into the touc

hscreen, then select [Upload] in the pop-up wi

ndow on the HMI.

⚫ Step ②: Configure the download settings in the 

pop-up window on the HMI, enter the download 

password (the default password is 111111), and 

then click [OK].

⚫ Step ③: Select the upload path of the project in 

the pop-up window on the HMI, click [OK], wait 

for the prompt indicating successful upload, an

d then unplug the USB flash drive.

Basic Functions of the Software

Note: Do not interrupt the connection to the HMI during the downloa

d process, and refrain from performing any other operations; otherwi

se, it will affect the transmission. 



◼ Project Upload - Decompile 功能

function

⚫ Step ④: The project files uploaded via USB or netw

ork cannot be directly opened with software and n

eed to be decompiled. Click [Decompile] for the pr

oject file in the menu bar. The steps are as follows:  

1. Select the uploaded EXHMI project file.  

2. Set the name and file path for the decom

piled project.  

3. Enter the decompilation password set for 

the project (default password: 111111).  

4. Click [Decompile].

◼ Step ⑤: After waiting for the decompilation t

o complete, use the software to open the co

mpiled HMI project file.
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◼ Multilingual and Font Explanation 功能

function

⚫ Click [Project] -> [Language & Font] in the menu bar.

① Languages: Configure the number of languages supported by the project and the fonts used for ea

ch language. Up to 23 different languages can be displayed.

② Non-ASCII Fonts: Configure fonts for non-ASCII characters (e.g., Chinese, Japanese, Cyrillic).

③ Fonts: Displays the fonts currently used in the project file. You can replace existing fonts wi

th other available ones.

⚫ [Language & Font] You can set the language and font of the existing labels.

①
② ③
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⚫ When using multiple languages in a project, first create 

a text label library, enable the text label library on the c

ontrol's label page, then select the required labels. The 

steps are as follows:

◼ Explanation of Multilingual Usage 1 功能

function

Step ①: Click [Project] -> [Label] in the menu bar.

Step ②: In the text library window, click [Add], 

set the title and number of states in the text label wi

ndow, and then click [OK].

Step ③: Select the newly created label and click 

[Settings] to edit the language content for different 

states or modify the number of states.

③

②

注：文字标签库可以导入/导出excel文件后，再进行编辑。
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◼ Explanation of Multilingual Usage 2 功能

function

Note: *1. Only the text size can be set individually in the text properties. Other properties, 

including text color, alignment, and blinking, are the same as those of Language 1.

Step ④: In the [Labels] tab of the component pr

operties window, check [Use Text Library], then selec

t a predefined text label from the drop-down menu on 

the right. *1 Example using the [Multi-State Indicator] 

component:

Step ⑤: Change the value of system register LW-9

134 (current language in use) to switch the HMI's curr

ent language. The valid range is 0-22, corresponding t

o a maximum of 23 languages. Use the [Multi-State Sett

ing] component to configure a cyclic increment (JOG+) 

function (Settings: Minimum 0, Maximum 2, Increment 1) 

to control language switching, as shown below:
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◼ Importing External Images into the Gallery 1 功能

function

⚫ Click [Project ] -> [Picture] in the menu bar 

to pop up the Image Management Window. 

The steps for importing external images ar

e as follows:

Step ①: After selecting the Project Files tab i

n the Image Management Window, click [Add Picture], c

hoose the picture library to which you want to add im

ages, and then click the [Add] button.

Step ②: Select the image(s) you want to insert 

and click [Open].

Step ③: Click [Confirm] in the pop-up editing w

indow to complete loading the external image. For mul

tiple states, continue to add new images.
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Step ④: In the [Picture] tab of the component p

roperties window, check [Use picture], then click the 

[Library] button.

功能

function

Step ⑤: In the [Project] tab of the picture Man

agement Window, select the newly added picture and cl

ick [OK] to complete the configuration.

Basic Functions of the Software

◼ Importing External Images into the Gallery 2



◼ Explanation of Address Label Libraries 功能

function⚫ Defining frequently - used addresses in the 

address label library *1 can save the tedious 

address input. The steps for using label com

munication are as follows:

Step ②: In the Address Label window, set releva

nt attributes such as Name, Address, Synchronization 

Address, etc *2, then click [OK] to complete adding th

e address label.

Step ③: Editing window to use the address label.

Step ①: After clicking [Project] → [Address] i

n the menu bar, click [Add] in the Address Label Libr

ary window.
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◼ Custom Boot Screen 1 功能

function

⚫ Here are the steps to design the boot screen for an HMI: 

Step ②: In the Boot Screen Generation window, y

ou can preview the image. Click [Generate Image Resou

rce File] to save it to your computer.

Step ①: Click [Tools] -> [Make Boot Logo] in th

e menu bar, then click [Add Image] in the Boot Screen 

Generation window; select the boot screen image in th

e window.
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功能

function

② Finally, select the target HMI device, click 

[Download], and wait for the HMI to restart and load 

the custom boot screen.

Step ③: Click Download Project in the project f

ile, check User-Defined Boot Screen, then click Brows

e. In the pop-up window, select the newly generated b

oot screen source file (e.g., Custom Boot Screen_800x

480_logohmi).
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◼ System registers 功能

function
◼ Open [Project] → [Address ] in the menu bar, and expand the System Register branch to view.
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