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◼ Explanation of data sampling function
Data sampling

组态

WINCC
⚫ [Data sampling] the sampling method used to configure data sampling.

Step 1: Select [Data History] -> [Data Sampling], 

and the Data Sampling Properties dialog window will 

pop up.

Step 2: Click the [Add] button to pop up the data hist

ory dialog box, and set relevant parameters such as sampl

ing method, sampling address, and maximum sampling q

uantity in the dialog box.

1. Sampling method: Set the conditions for executi
ng data sampling: periodic execution or bit/word condit
ion triggering.

2. Batch sampling: Collect data starting from the 
data source address as the sampling data start address, 
and collect data from the continuous addresses of multi
ple formats set in [Channel Number].

3. Data Recording: If [Auto Stop] is not selected, the HMI can r
etain up to 86,400 data entries. Once the limit is exceeded, the olde
st data entries will be deleted starting from the oldest. If [Auto Sto
p] is selected, data sampling will stop once the maximum number 
of entries in [Timed Mode Maximum Entries Maximum Data] is reac
hed.



◼ Explanation of data sampling function
Data sampling

组态

WINCC

6. Pause sampling control address: When the state 

of the specified address is triggered, sampling will be 

paused until the state of the specified address is rest

ored;

4. Non-batch sampling: Collect data at the spe
cified address;

5. Clear real-time data address: When the conf
igured conditions are met, the sampled data in the 
trend chart [real-time mode] will be cleared, and t
he number of sampled data will be reset to zero, bu
t this will not affect the historical sampled data 
saved in the file;

7. Full sampling notification address: When the nu

mber of sampled data reaches the maximum, write ON to t

he specified address;

8. Historical data: Set the location where sampled 

data is saved;



◼ Explanation of Trend Display function
Data sampling

组态

WINCC
⚫ [Trend Display] Components will be set in [Data sampling], and the data will be plotted using contin

uous line segments.

Step 1: Click [Data History] -> [Trend Display] in t

he menu bar to pop up the property dialog box of the t

rend chart component.

Step 2: In the dialog box, select the data source for th

e trend chart under [General Properties];

1. Data Sampling Component Index: The data source 
required for plotting;

Step 3: Click the [Trend Display] tab in the trend char

t component properties dialog box. Users can select the gr

id, time scale, and date/time format they wish to display.



◼ Explanation of Trend Display function
Data sampling

组态

WINCC

Step 4: Click the [Channel] tab in the trend graph compo

nent properties dialog box. Users can select the sampling dat

a channels they want to display on the trend graph compone

nt and set the curve properties and maximum/minimum valu

es for each channel.
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◼ Event (Alarm) Log
Alarm function

组态

WINCC
⚫ [Event (alarm) Log] Used to configure event trigger conditions and content.

Step 1: Click [Data History] -> [Event (Alarm) Log] 

in the menu bar to pop up the event log properties dia

log box.

Step 2: Click the [Add] button to pop up the event (al

arm) log dialog box, and set parameters such as event cate

gory, level, type, and conditions in [General Properties];

1. Category: Group alarm events; 

2. Level: When the number of events exceeds the syst
em's maximum value (default is 1000), events of lower lev
els will be deleted from the records; 

3. Type: Select the event trigger type, which can be s
et to trigger based on bit register status or word register v
alue conditions;

Specify the storage location of the event log 
file. When an event is triggered, the HMI will save 
the log to the historical data. When using the onli
ne or offline simulation function, it will be store
d in the ParsePro/project name/ftp folder under the 
installation directory. Set the conditions for data 
sampling execution.



◼ Event (Alarm) Log
Alarm function

组态

WINCCStep 3: Click the [Information] tab in the event (a

larm) login dialog box. This allows the user to set the i

nformation content to be displayed in the alarm bar, a

larm display, and event display components when the 

event is triggered.

Step 4: Click on the [Statistics] tab in the event (alar

m) log dialog box. You can view the number of times the e

vent occurred and the cumulative event statistics for the c

orresponding address.
1. Writing to the alarm display/event display 

components when the event is confirmed: When the ev
ent is confirmed, the confirmation value is written 
to the confirmation address set in the correspondin
g event display and alarm display components; 

2. Alarm sound: Set the sound emitted by the H
MI when the event is triggered; this feature is sti
ll under development; 

3. Monitoring address: Configure the number of 
registers and addresses that can be added in the text 
content



◼ Alarm bar function
Alarm function

组态

WINCC
⚫ The [alarm bar] displays events defined in [Event Log] a running light format, and the event content t

hat currently meets the trigger conditions.

Step 1: Click [Data/History] -> [Alarm Bar] in the menu 

bar to pop up the alarm bar component properties dialog bo

x. Set the [General Properties] in the dialog box.

Step 2: Click the [Sort] tab in the alarm bar compone

nt properties dialog box. Users can select the information 

they want to display, set the display order, and set the dat

e/time format.1. Displayed category range: Configure the event g
roups displayed in the alarm bar component.



◼ Alarm Display function
Alarm function

组态

WINCC
⚫ [Alarm Display]The components are displayed in tabular form as defined in [Event Log], and the event 

content that currently meets the trigger conditions.

Step 1: Click on [Data/History] -> [Alarm Display] in t

he menu bar to bring up the alarm display component pro

perties dialog box. Set the [General Properties] in the dialo

g box:

Step 2: Click the [Alarm] tab in the alarm display com

ponent properties dialog box.

1. Confirmation Address: The confirmation value 
set in [Event Log] -> [Write to Alarm Display/Event Disp
lay Component when Event is Confirmed] will be outp
ut to the specified address;

1. Confirmation Method: Set the confirmation metho
d after the event is triggered, which can be set to single-cli
ck or double-click;



Alarm function
组态

WINCC

Step 3: Click the [Font] in the Alarm Display Com

ponent Properties dialog box. Users can configure the 

content and style of the title bar of the alarm display c

omponent list.

4: Click the [Sort] in the Alarm Display Component Pr

operties dialog box. Users can select the information they 

want to display, set the display order, and set the date/tim

e format.

◼ Alarm Display function



Alarm function
组态

WINCC
⚫ The [Event Display] component displays events defined in [Event Log] that currently meet the trigger 

conditions in tabular form.
Step 1: Click on [Data History] -> [Alarm Display] i

n the menu bar to bring up the alarm display compon

ent properties dialog box. Set the [General Properties] 

in the dialog box:

Step 2: Click the [Event Display] tab in the Event Displ

ay component properties dialog box.

1. Maximum number of events: The maximum numb
er of events that the component can display. When the nu
mber of events displayed by the component exceeds the 
maximum number, new events will be displayed at the top
, and the last event will be deleted.

◼ Event Display function



Alarm function
组态

WINCC

。Step 4: Click the [Empty Warning] tab in the Ev

ent Display component properties dialog box. You can 

set the text to be displayed on the component before 

an event is triggered.

Step 3: Click the Font tab in the Event Display co

mponent properties dialog box. Users can configure t

he content and style of the title bar of the alarm displa

y component list.

◼ Event Display function



Step 5: Click the [Sort] tab in the Event Display component proper

ties dialog box. Users can select the information they want to display, s

et the display order, and set the date/time format.

Alarm function
组态

WINCC

◼ Event Display function



01

02

03

04

Data sampling

Alarm function

Operation Log Settings

Recipe Function
CONTENTS

05

06

Macro Command Functions

Pay by Installments



◼ Operation Log Settings Function
Operation Log Settings

组态

WINCC
⚫ [Operation Log] can be configured to record the operations required in the HMI. 

Step 1: Click [Data History] -> [Operation Log sett

ings] in the menu bar to open the Operation Log Prope

rties dialog box. 

Step 2: Select Enable, then set the write function co

mponents to be recorded. 

Step 3: In [Storage Settings], select the maximum nu
mber of steps to be displayed for the HMI operation.

Step ④: Configure the control address. Entering a sp
ecific value will execute the corresponding command for t
he selected operation log and return the command execut
ion result. The control address defaults to LW(n), and the c
ommand execution result is stored in LW(n+1).



◼ Operation Log View Function
Operation Log Settings

组态

WINCC
⚫ [Operation Log View] can display the component operation steps configured in the operation log.

Step 1: Click [Data History] -> [Operation Log Vie

w] in the menu bar to pop up the Operation Log View c

omponent properties dialog box.；

Step 2: Select [Operation Log View] -> [General Properties] 

to configure the component's title color and font properties.

Step 3: Select [Operation Log View] -> [Sort] to configure 

the information you want to display, set the display order, and 

set the date/time format.
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◼ Recipe Database Function
Recipe Function

组态

WINCC
⚫ [Recipe Database] Contains the project name, data type, and other related attributes of the recipe.

Step 1: Click on 【Data History】 -> 【Recipe Dat

abase】 in the menu bar to open the Recipe Database 

Properties dialog box;

Step 2: Select the system registers in the Recipe Data

base Properties dialog box to view the registers related to 

recipe operations;

1. Recipe List: Add or delete recipes, with a maxi
mum of 100 recipes; after clicking 【Add】, you can co
nfigure the display content properties of the recipe vie
w component in the table;



◼ Recipe View Function
Recipe Function

组态

WINCC
⚫ The [Recipe View] component is used to view all items and values set in the recipe group.

Click [Data History] -> [Recipe View] in the menu bar to pop up the Recipe View component's 

property dialog box. Set the [General Properties] in the dialog box:

1. Recipe Directory : Select the recipe name you want to view from the drop-down menu.



◼ Recipe View Function
Recipe Function

组态

WINCC
⚫ The [Recipe Transfer] component is used to transfer data from the selected recipe group to a 

specified address, or to write data from a specified address to a specified recipe group.

Click on the menu bar [Data History] ->[Recipe Transfer] 

to open the recipe transfer component properties dialog box. 

In the dialog box, set the [General Properties]:

1. Recipe Directory: Select the desired recipe na
me from the drop-down menu; 

3. Mode: ① Manual: Execute recipe transfer oper
ation when clicked or released; ② Trigger: Read recipe 
data to the specified address;

2. Transfer Mode: ① Device Data Write to Recipe: 
Write data from the specified address to the recipe; ②
Recipe Data Write to Device: Read recipe data to the sp
ecified address; 

①

②
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◼ Macro Command Functions
Macro Command Functions

宏指令

script
⚫ [Macro Command] is used to manage all macro command files.

Step 1: Click [Project] -> [Macro] in the menu bar. The Macro 

Instruction Library Properties dialog window will pop up;

1. Macros that have been compiled successfully are in t

he [Compiled Successfully] list, and macros that have not bee

n compiled are in the [Unfinished Compilation] list; each proje

ct packages up to 255 macros.

2. Click the [Add] button to pop up the macro 
command editor dialog window.



2.Start execution conditions: After checking,
set the conditions for macro instructions to
prohibit execution;

◼ Macro Editor Function
Macro Command Functions

script
⚫ The [Macro Command Editor] is used to write macro code.

Step 1: Set macro command parameters;

1. Set the name and number of the macro command.

3. Periodic execution: After checking this box, the macro 
will be triggered periodically at the set frequency.

4. Execute once when HMI starts: This macro will automatically 
execute once when HMI startup is complete;



Macro Command Functions
宏指令

script

5. Above the editing area, there is a toolbar,
providing [Retract], [Restore], [Cut], [Copy],
[Paste], [Delete], [Annotate], [Find] and other
buttons;

6. Password protection: After user sets
password protection, when users want to modify the
script, users need to enter the correct password.
When three consecutive password errors, users need
to restart the system to re-enter the password;

◼ Macro Editor Function



◼ Macro Command Writing
Macro Command Functions

宏指令

script

1.  A macro must have exactly one main function 

[void main(void)] to start the execution of the macro. 

The format is as follows:

2. Variables: Variable declarations must be placed 

before macro statements. Otherwise, if the statement is 

placed before the variable declaration, the macro will n

ot compile. Common variable types are as follows:

3. Arrays: Macro instructions support one-dimensional 
arrays (indexes start from 0), with the following format: An  
array Data of 16-bit integer type, containing Data[0] to Data
[9], with an initial value of 0;



◼ Macro Command Writing
Macro Command Functions

宏指令

script4. Operators: Specify how data is manipulated and 
operated on, including assignment, arithmetic (addition, 
subtraction, multiplication, division), comparison,  logic
al, and shift operations;

The precedence of all the above operators:     
operators inside parentheses > arithmetic operators > 
shift and bitwise operators > comparison operators > 
logical operators > assignment operators;

1. Assignment and arithmetic operations 

2.Comparison operations 

4. Shift operations 

3. Logical operations 

5. Bitwise operations 



◼ Macro Command Writing
Macro Command Functions

宏指令

script5. Built-in functions: The macro instructions themselve

s provide some built-in functions, which can be viewed in th

e [Description] section at the bottom right of the macro instr

uction editor;  

For example, retrieving/transmitting data from connec

ted devices is as follows: 

①GetData: Retrieves data from a specified add
ress register, in the following format; 

②SetData: Writes data to a specified address 
register; 

6. If statement format:

Example: When the value of Data[0] is less tha
n 10, increment Data[0] by 1; when the condition is 
not met, assign 0 to Data[0];

Example: When the value of Data[1] is less tha
n 10, increment Data[1] by 2; when the value of Dat
a[1] is greater than or equal to 10 and less than 2
0, increment Data[1] by 1;



8. Quick variable declaration: Click the “Generat

e Variable” button at the bottom left of the macro co

mmand editor, and set the variable name, data type, i

nitial value, etc.

◼ Macro Command Writing
Macro Command Functions

宏指令

script

7. For command format:

Example: Determine the number of values in the 
array Data[0]~Data[9] that are less than 10, and as
sign the result to Data[10]; determine the number o
f values in the array Data[0]~Data[9] that are grea
ter than or equal to 10 and less than 20, and assig
n the result to Data[11].

Example: Declare an array Data, with a data typ
e of 16-bit integer array Data, containing Data[0]~Da
ta[9], with an initial value of 0, as shown below:



10. Save & compile: Click the [Generate Variable] 

button at the bottom left of the macro command edit

or to set the variable name, data type, initial value, etc.

◼ Macro Command Writing
Macro Command Functions

宏指令

script

9. Quickly call built-in functions: Click the [Functi

on] button at the bottom left of the macro command e

ditor to set input and output variables *1, etc.

Example: Read the data from controller MW1000 
into variable Data[0]

Note: *1. When using quick calls to built-in functions, pay attention to the data 

format required by the function when selecting input/output variables.
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◼ Pay by Installments function
Pay by Installments

组态

⚫ [Installment Payments] Used to configure installment payment trigger conditions and content, set installment 

payment modes, installment periods & passwords, due date reminders, and other functions.

Step 1: Click [Project] -> [Pay by Installment] in t

he menu bar to bring up the installment payment pro

perties dialog box.

Step 2: After selecting to enable installment pay

ments, you can choose the installment payment mode:

1. Static installment payment: Determine whether 
the payment is due based on the set time; set the maxim
um number of installments, ranging from 1 to 36; then s
et the password and due date (year/month/day/hour/mi
nute) for each installment in the table below.

2. Run time installment payment mode: Calculate t
he due date based on the set run time to prevent users fr
om continuing to use the HMI by modifying the time or d
isconnecting the power supply.



Pay by Installments
组态

WINCC

5. Super password: Once selected, when the expira
tion time is reached, entering the correct super passwor
d will directly close the installment payment function, m
eaning that the installment payment expiration interfac
e will no longer pop up.

6. Dynamic Key: After the HMI expires, if the user wish
es to continue using it for a few more days without countin
g toward the installment period, the dynamic installment p
ayment mode can be used. After configuring the dynamic k
ey, go to the menu bar [Project File] -> [Password Generatio
n] to generate a new password. When the expiration date is 
reached, enter the generated password and set an addition
al expiration time.

3. Expiration reminder: Once enabled, a designated 
window will pop up based on the preset advance time and 
reminder frequency.

4. Expiration pop-up window number: Set a design
ated window to pop up when the expiration time is reac
hed.

◼ Pay by Installments function



◼ Password Generator Tool Function
Pay by Installments

tool
⚫ [Installment Payment] Used to calculate a new password in cooperation with the dynamic key in inst

allment payments.

Step 1: Click [Project] -> [Password Generation T

ool] in the menu bar to bring up the password generat

ion tool properties dialog box.

Step 2: In the password generation tool properti

es dialog box, enter the key for the installment payme

nt settings and set the expiration time.

After the HMI expires, if the user wants to continue usin
g it for a few more days without counting the number of day
s, they can use the dynamic installment payment model.

Step 3: Click the [Generate Password] button to 

generate a new password. After the customer enters t

he generated password to unlock, they can set an addi

tional expiration time, as shown in the diagram below:

First period 
expired.

Second 
period.

Extend the 
time to

Enter the static password for 

the first period.

Enter the calculated 

dynamic password.

Second 
period.

Enter the first static 

password

Enter the dynamically 

generated password

Extend the 
time to

。。。
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